PDF  | Print |

 

Beam Draw

version 3.0.2

Users Guide

 

Created by Joshua Benghiat

Joshua Benghiat Lighting Design

 

Introduction

Requirements | Installation | Support

Getting Started

Adding to an Existing Workspace | RegistrationOverview

Workflow

In Detail

 

 


Introduction

 Requirements

Vectorworks 12 or higher

 

 Installation

If you haven't already, download the Beam Draw Installer from the JBLD downloads page.

 

Make sure Vectorworks is not running.  Run the Beam Draw Installer.  Select your version of Vectorworks. The installer will install a folder called "-JBLD Beam Draw" in your user Plug-Ins folder, containing the Beam Draw plug-in objects and menus.

 

The Macintosh installer allows you to select a custom location for your Plug-Ins folder.  Windows users with a custom user data location or Mac users having trouble with the installer can download the "Raw installer" and manually drag the "-JBLD Beam Draw" folder to Plug-Ins.  For more information, see this FAQ.

 

 Support

Please visit http://BenghiatLighting.com/software/support for support options and to report bugs.  

 

You may also email software(at)BenghiatLighting.com.

 



Getting Started

When the installation completes, start VectorWorks and select Tools>Workspaces>Beam Draw Standard or Tools>Workspaces>Beam Draw Spotlight.  The Beam Draw workspace is similar to the VectorWorks Standard and SpotLight workspaces, but with a Beam Draw palette containing the Beam Draw Tools, and a Beam Draw menu. Use the About Beam Draw... menu item or the About... button in Object Info to enter your Beam Draw registration or demo code.

 

 Adding to an Existing Workspace

To add Beam Draw to an existing workspace:

  1. Select Tools>Workspaces>Workspace Editor.
  2. In the Menus tab, click the disclosure triangle next to Beam Draw in the list of Menu categories on the left hand side.
  3. Drag all the commands to an existing menu on the right or create a new menu.
  4. Select the Tools tab.
  5. Click the disclosure triangle next to Beam Draw in the list of Tools categories on the left hand side.
  6. Drag the all the Beam Draw Plug-In Objects to an existing palette on the right or create a new palette.
  7. If you want to use the Beam Draw tool set icon, you can find it installed in your user workspaces folder.
  8. Click OKScreen-Cast-Icon-Sm

BD_Wksp_Edit

 

 Registration

The first time you use the Beam Draw, you will be asked for a registration number or demo code.  You can also access the registration dialog through the "About" button in the Object Info palette or the About Beam Draw... menu item..  The Beam Draw objects will not draw without a valid code. 

 

 Overview

Beam Draw allows you to visualize a beam of light in both plan view and 3D, helping you to choose proper instrument type and location. The beam instantly redraws if you change its beam angle, focus position, or instrument position.

The following diagram shows some of the terminology used by Beam Draw:

Beam example_opt

BD_Placed-01

Beam Draw utilizes Plug-In Objects, meaning it draws beams according to a set of user-definable parameters, including beam angle, position height, and face plane. You will find a full list of parameters described for each object. You can edit an object’s parameters in the Object Info Palette.

As with all Plug-In Objects, the first time you place a beam in a document, VectorWorks will ask you for default parameters. You can set the default object parameters for the document by selecting the object’s tool, then clicking on the parameters button Plug_In_Pref_Button in the mode bar.

Mode_Bar

 

The fill Beam Draw package includes several plug-in objects and menus.  Please visit the Beam Draw Quickguide page for a brief introduction to each Beam Draw component.


 Workflow Screen-Cast-Icon-Sm

Here is a sample workflow for using Beam Draw to visualise a system of lights.  Please see the Quickguide as well as the detailed descriptions of each component to determine how to best incorporate Beam Draw into your design process.

 Insert in the Drawing

  1. Click on the Beam Draw Tool icon Beam_Draw.
  2. Click on the drawing in the approximate plan location where you would like the light to hang.
  3. Drag the beam edge or focus point (indicated by a locus) to the point you would stand when focusing the light.  The size and shape of the beam will change accordingly.
  4. Alternatively, you can insert the beam at its focus point and drag the boxed control point to a hanging position.  Your cursor will change to a double arrow when it is over the control point.
  5. You can also use nudge (shift+arrow) to fine tune the focus point.

 Adjusting Parameters

Many aspects of the beam are controllable though parameters in the Object Info Palette.  

You'll want to make sure your beam is being calculated from the correct height with the Position Height parameter.  Use Distance to Clamp to drop (positive distance) or raise (negative distance) the origin of the beam below the position to its focal point.  If you have lighting positions with z height values, press the Pickup Z Height button at the bottom of Obj Info.

Towards the bottom of the parameters is an option to Show Floor, showing the beam at both the face and floor planes.

You can set the Field and Beam angles towards the top of the parameters.  Use a Beam angle of 0 to work only with the field angle.  You can also press the Get Light Info Data button to access the beam and field angles and candlepower stored in the Light Info Record of your symbols.  The symbols that shipped with Spotlight as well as those commercially available, like Soft Symbols, have photometric data already attached to them.  Use the Use Light Info for Selected menu command to apply Light Info data to more than one beam object.

To visualize shutter cuts, make sure Show Shutter Cuts is checked.  You can drag shutters via a control point right in the drawing or enter a depth and rotation in Obj Info.

 Viewing the Beam in 3D

  1. Switch to a 3D view.  The beam will continue to reshape if moved in 3D.
  2. You may want to hold down the shift key while moving the beam in 3D so its focus height does not change.

BD_3D

 Reverse and Repeat

You can easily reverse and repeat beams across the x=0 centerline.  Shutter cuts and bottle rotations are also reversed.  Note: do not use the mirror tool with Beam objects, or they will draw unpredictably.

  1. Select the beam objects you want to reverse and repeat.  They can be any mix of Beam Draws and Beam Draw Pars.
  2. Select the menu Reverse and Repeat Beams.

BD_R-and-R

 Creating a Consistent System of Lights

  1. Use Beam Draw or Beam Draw PAR to select the proper position, beam angle, and focus of one light.  You may find it useful to have a paper section in front of you, or to examine the beam in a 3D side view.  Hint: Beam Draw also computes the distance and angle to the face.
  2. Now change the Redraw parameter from Dynamic to Fixed.
  3. You can now duplicate, duplicate array, or option/alt-drag the beam, and the instrument location will move, keeping the shape of the beam constant.

 Channeling Beams

If you're working with a single system of beams, you may find it useful to assign channel numbers.  
  1. If no beams are selected, the command channels all beams on the current layer.  Otherwise the command works with selected beams of any type.
  2. Choose the menu Channel Beams.
  3. You will see a dialog allowing you to select the first channel and the direction channels will number. 
  4. BD_Channel_DialogThe channel displays at the focus point.  You can change the font and size using the Text menu.
  5. Select a beam, and at the bottom make sure Show Paperwork Info is checked.  You can manually set channel and purpose here.  Those fields can automatically transfer when a beam is turned into a Spotlight Lighting Device.


BD_Rough_Style

  1. Uncheck the Show Beam parameter and select Display Field Angle.  The beam object reduces to the focus point (if it's shown) and the instrument location, with the channel, field angle, and direction displayed.  This is useful for creating a rough plot from your beans.

 Converting Beams to Spotlight Lighting Devices

  1. Select the Beam Draw and or Beam Draw PAR objects you wish to convert.  If no beams are selected, the command converts all beams on the current layer.
  2. A dialog will ask you to match each field angle with a symbol in your document.  There is also a set of symbols whose field angles are close to your selected beam.BD_Convert
  3. Choose if you want the symbols aligned to the drawing grid and rotated to the neatest 90°.
  4. For now, do not delete beam objects after they are converted.
  5. Any channel and purpose data entered into your Beam Draw objects will be transferred to your Lighting Devices.

 Move Beams to a Layer

  1. Select the beams you wish to file on another layer.  If no beams are selected, the command converts all beams on the current layer.
  2. Select the Move Beams to Layer menu.
  3. You will be prompted for a suffix name for the layer, usually the system name.  The layer name can be new or existing.
  4. The beams are moved.  New layers are hidden by default.

 Making a Magic Sheet

If you channeled your beams, you can easily lay out a magic sheet.

  1. Switch to a sheet layer.
  2. If you like, use viewports to create a cropped, miniature version of the set.  Make sure the 0,0 point of your drawing is snappable in the viewport.
  3. Select the Beam Draw Magic tool.  Beam_Draw_Magic
  4. Click in the drawing at the 0,0 point of your magic sheet.  
  5. Use Object Info to pick a layer -- all channeled beams will appear as numbers in the Magic object.  
  6. Set a scale in Obj Info (e.g. 1/8"=1'-0" would be 96).  
  7. Set the font for the channel numbers via the text menu.  
  8. Use Object Info to provide an offset for all channels (e.g. numbers are +10) or show them reverse and repeated.
  9. The Move by Points basic tool can be useful for duplicating your Magic object / viewport combination.

 


 In Detail

 Beam Draw

Overview

Beam Draw allows you to visualize the coverage of a beam of light in plan view.  Each beam is a separate Plug-In Object with easily adjustable hanging and focus points.  Beam Draw will reshape as you move the focus across the drawing, and it will even show hyperbolic and triangular intersection with the face plane.  Beam Draw can also show how the same beam will hit the floor as well as show the beam in 3D views.

Instructions

  1. Click on the Beam Draw Tool icon Beam_Draw.
  2. Click on the drawing in the approximate plan location where you would like the light to hang.
  3. Drag the beam edge or focus point (indicated by a locus) to the point you would stand when focusing the light.  The size and shape of the beam will change accordingly.
  4. Alternatively, you can insert the beam at its focus point and drag the boxed control point to a hanging position.  Your cursor will change to a double arrow when it is over the control point.
  5. You can also use nudge (shift+arrow) to fine tune the focus point.
  6. Adjust parameters of the beam in the Object Info palette.
  7. If you are viewing shutter cuts, you can adjust the shutters in Object Info as well as by dragging the four control points in the drawing.

See the Workflow for more details.

Parameters

The Beam Draw parameters can be edited in the Object Info Palette.  To set parameter defaults, see the Overview.

Parameter Description
x, y

The coordinates of the focus point.

Z

The height from which trims are measured, usually 0.  If you are measuring trims from a show deck or platform, enter that height here.

Rot

Rotation is handled by the script.  Should always be 0.

Instrument X, Y

The coordinates of the lighting instrument.

Instrument Distance X, Y

The x and y distances from the focus point to the lighting instrument.

Position Height

The height of the lighting position.

Distance to Clamp

The distance from the hanging position to the source point in the lighting instrument.  The height of the beam is computed as Position Height - Distance to Clamp.

Field Angle

The field angle of the beam.

Beam Angle

The beam angle of the beam.  If you do not want to draw the beam angle, enter a value of 0.  If you only want to draw the beam angle, enter it in field angle.

Peak Candela

The peak candela of the beam.  This is optional and used for computing footcandles.

Show Beam

Show or hide the beam ovals. If hidden, an arrow at the instrument location will show which direction the beam focuses.

Display Field Angle

Select to show the field angle indicated next to the instrument location.

Show Focus Point

If checked, a locus is drawn at the focus point.

Indicate Inst. with

A box or locus at the instrument location.

Show Shutter Cuts

Select for the ability to specify shutter cuts.  If you hide cuts, the shutter parameters will still be retained.

Shutter Depth

The percentage to push in a shutter.  100% is at the focus point.  You can also use control points in the drawing to drag shutter cuts.

Shutter Rack

The angle of each shutter

Resolution

Select “Low” to see the outlines of the beam more clearly in 3D.

Resolution Factor

Set the resolution for the Low Resolution option.  360 is a fairly full resolution.  4 should be the minimum.

Face Plane

The height of the plane on which beams are drawn.  Usually 6’0”

Show Floor

If checked, will draw the beam at both head height and as it falls on the floor.

Add Light

Adds a light object with the same parameters of the beam.  The light will only show as a pool of light using RenderWorks rendering.

Redraw

In dynamic mode, the lighting instrument remains fixed and the beam reshapes as you move it.  In Fixed mode, the lighting instrument will move as you drag the beam, keeping the shape constant.  Fixed mode is useful for duplicating a beam into a system of lights.

True Distance

The actual distance between the instrument and focus point.  Useful for finding the light’s intensity at the face.  Do not edit this field as it is computed by the object script.

Angle to face

The angle from the face to the light.  Straight top light is 90°.

Pan

The degrees from straight up on the page (US, North, etc)

Tilt

The degrees from straight down.

Maximum Width

The maximum width of the beam at head height.

Footcandles

The computed intensity of the light.

Show Paperwork Info

Shows options to indicate a channel and purpose to keep track of your beams.

Channel

The channel number will show at the focus point if the beam is shown or at the instrument location if it is hidden.  The channel can be used to create a Beam Draw Magic sheet object.  The channel will also transfer when a beam is converted to a SpotLight lighting device.

Purpose

The purpose will transfer when a beam is converted to a SpotLight lighting device.

Get Light Info Data

Brings a dialog where you can select beam and field data from the symbols in your document and the symbols in your default file.  Beam Draw will display the footcandles each unit type will output at the current throw.

Reset Shutters

Pulls out all the shutters.

Pickup Z height

Will change the position height to the z height of any 3D object below the instrument location.  This does not change dynamically and will happen when you press the button.

 


 

 Beam Draw PAR

Overview

Beam Draw PAR functions just like Beam Draw, only it visualizes elliptical beams. You can set the bottle rotation to any angle.

Instructions

  1. Click on the Beam Draw Tool icon Beam_Draw_PAR.
  2. Click on the drawing in the approximate plan location where you would like the light to hang.
  3. Drag the beam edge or focus point (indicated by a locus) to the point you would stand when focusing the light.  The size and shape of the beam will change accordingly.
  4. Alternatively, you can insert the beam at its focus point and drag the boxed control point to a hanging position.  Your cursor will change to a double arrow when it is over the control point.
  5. You can also use nudge (shift+arrow) to fine tune the focus point.
  6. Adjust parameters of the beam in the Object Info palette.
  7. You can rotate the beam in Object Info or by dragging the control point in the drawing that is near the beam's focus point. Screen-Cast-Icon-Sm

Parameters

The Beam Draw PAR parameters can be edited in the Object Info Palette.  To set parameter defaults, see the Overview.

Parameter

Description

See Beam Draw Parameters, with the following exceptions

Shutters

PAR Objects cannot show shutter cuts

Field Angle H

The horizontal field angle

Field Angle V

The vertical field angle

Beam Angle H

The horizontal beam angle

Beam Angle V

The vertical beam angle

Bottle Rotation

The angle of bottle rotation.  The bottle can also be rotated via a control point in the drawing.

Get Light Info Data

Will show and return H & V field and beam angles.

 

 


 

 

 Beam Draw Section

Overview

Beam Draw Section allows you to draw a 2D triangle of light showing an instrument's spread in section.  You can select beam and field angles for the beam, visualize shutter cuts.  You can display a figure as well as identify an area with minimum coverage width.

In order to keep beams from extending infinitely, the Beam Draw Section has four display modes, selectable in object info:

 Mode Description
Control Points The beam will terminate at the two draggable control points that also define shutter cuts.  Shutter cut control points are available in the other modes, but they only affect the beam ends in this mode.
Horizontal The beam ends will terminate on a line horizontal with the focus point.
Vertical The beam ends will terminate on a line vertical with the focus point.  This option is useful for visualizing illumination of drops or scenery.
Focus Area

The beam ends will terminate at the floor, as defined bu the face plane.  In this mode, you also have the option to view a figure whose head is at your focus point. 

BD_Section

 

Instructions

  1. Click on the Beam Draw Section Tool icon Beam Draw Section2.
  2. Click and drag from the gate of your light to your focus point.  If you would rather drag in the opposite direction, use the Beam Draw Section from FP Tool.
  3. If you don't have representations of lighting instruments in your section, you can end the line at the hanging position.  Next, click the button labeled "Shift by clamp height," and your beam will compensate.
  4. Adjust the section's options, including Field Angle in Object Info.
  5. To visualize shutters, make sure "Draw Shutters" is selected in Object Info.  You will see a control point handle towards the ends of the beam section.  Drag the point, and the shutter cut will pass through the point.  You cannot open the shutters wider than the field angle permits.  Screen-Cast-Icon-Sm

Parameters

Parameter Description
x, y The coordinates of the ogirin of your beam, the gate of your light.
z If you want to use the 2D section in a 3D plane, this is the distance above the working plane.
Rotation The angle from the light to the focus point.
Throw Distance  The distance from the light to your focus point.
Field Angle  The field angle of the beam.
Beam Angle The beam angle of the beam.  If you do not want to draw the beam angle, enter a value of 0.  If you only want to draw the beam angle, enter it in Field Angle.
Peak Candela  The peak candela of the beam.  This is optional and used for computing footcandles.
Display Options 
Show Beam  Deselect to hide the beam edges.  You will see a locus at the origin of your beam.  If shown, your figure will stay visible.
Display Field Angle Select to show the field angle indicated next to the beam origin. 
Show Shutters Select to show shutter cuts and the shutter cut control point handles.  If you deselect, any shutter cuts you made will still be preserved. 
Beam Ends This mode option determines where the ends of the beam terminate.   See the explanation in the Overview.
Extend  Extend the beam a distance beyond the points defined in Beam Ends.
Focus Area Options (Available in Focus Area Beam End mode)
Face Plane The height above the floor to which the beam focused. 
Show Figure Draws a 6' figure at the focus point.  You also have a control point handle at the figure's feet. 
Show area limits

Use this option to visualize coverage in the plane perpendicular to the section.  For example, say you want to see coverage for an 8' area.  After setting Area Width to 8', you will see a rectangular area that shows the limits of you 8' area.

BD_Area-Limits

Area Width  The width of minimum coverage shown in Show Area Limits.
Origin Options 
Show Clamp Position  Draws a locus at the instrument's C-clamp.
Distance to clamp  The distance from the light's gate to the hanging point of the C-clamp.
Shift by clamp height Shifts the origin of the beam down to compensate for the distance between the C-clamp and the light's origin at the gate.  Useful if you are drawing the section between the hanging position and the focus point, rather than a sectioned view of the lighting instrument.
-Computed Info- 
Throw Dist  The distance from the light to the focus point.
Angle to Face

The angle from the face to the light.  Straight top light is 90°.

Footcandles The computed intensity of the light. 
Maximum Width The maximum width of the beam at head height.
Reset Shutters Press this button to completely open the shutter cuts.  Useful if your shutters are all the way in to the center of the beam.
Get Light Info Data

Brings a dialog where you can select beam and field data from the symbols in your document and the symbols in your default file.  Beam Draw will display the footcandles each unit type will output at the current throw.

 

 


 

 Beam Draw Section from FP

Overview

This will insert the Beam Draw Section object, draw from the focus point to the hanging posiion.

Instructions

  1. Click on the Beam Draw Section from FP Tool icon Beam_Draw_Section_fron_FP.
  2. Click and drag from your desired focus point to your hanging position.

The resulting object is identical to that described in Beam Draw Section.


 Use Light Info for Selected

Overview

This command will utilize data attached to your symbols to provide you with a library of beam angles, field angles, and peak candela to apply to your Beam Draw Objects.  The data is extracted from the Light Info Record in your symbol definitions.  Thee symbols that shipped with Spotlight as well as those commercially available, like Soft Symbols, have photometric data already attached to them.

Data will be shown for symbol definitions in your current document as well as those in your Spotlight Default content folder.

Instructions

  1. Select any mix of Beam Draw, PAR, and Section objects.
  2. Choose the Use Light Info for Selected menu command.
  3. You will see any photometric data attached to the symbol resources in your drawing as well as those in the Spotlight Default content.
  4. Beam draw computes the brightness, in footcandles, for the first selected Beam Draw object in your drawing.
  5. Select a symbol whose data you want to use.
  6. If you only want to use the field angle, click Ignore Beam Ang, otherwise, click OK.
  7. Your beams will now use the data you selected.

BD_Light-Info

 


 

 Reverse and Repeat Beams

Overview

You can easily reverse and repeat beams across the x=0 centerline.  Shutter cuts and bottle rotations are also reversed.  Note: do not use the mirror tool with Beam objects, or they will draw unpredictably.

Instructions

  1. Select the beam objects you want to reverse and repeat.  They can be any mix of Beam Draws and Beam Draw Pars.
  2. Select the menu Reverse and Repeat Beams.

BD_R-and-R


 Channel Beams

Overview

If you're working with a single system of beams, you may find it useful to assign channel numbers.  The channels can be shown on the drawing, transfer to Spotlight Lighting Devices when using the Convert Beams command, and be used for creating magic sheets.

Instructions

  1. If no beams are selected, the command channels all beams on the current layer.  Otherwise the command works with selected beams of any type.
  2. Choose the menu Channel Beams.
  3. You will see a dialog allowing you to select the first channel and the direction channels will number.
  4. BD_Channel_DialogThe channel displays at the focus point.  You can change the font and size using the Text menu.
  5. Select a beam, and at the bottom make sure Show Paperwork Info is checked.  You can manually set channel and purpose here.  Those fields can automatically transfer when a beam is turned into a Spotlight Lighting Device.


BD_Rough_Style

Uncheck the Show Beam parameter and select Display Field Angle.  The beam object reduces to the focus point (if it's shown) and the instrument location, with the channel, field angle, and direction displayed.  This is useful for creating a rough plot from your beans. Screen-Cast-Icon-Sm

 

 


 Convert Beams to Instrument

Overview

This command allows you to insert Soptlight Lighting Devices or instrument symbols for each of the beams.  You can easily match beam angles to unit types.

Instructions

  1. Select the Beam Draw and or Beam Draw PAR objects you wish to convert.  If no beams are selected, the command converts all beams on the current layer.
  2. A dialog will ask you to match each field angle with a symbol in your document.  There is also a set of symbols whose field angles are close to your selected beam.BD_Convert
  3. Choose if you want the symbols aligned to the drawing grid and rotated to the neatest 90°.
  4. Choose whether you want beams converted to Lighting Devices or just regular symbols.
  5. You can opt to delete beams after they are converted, though most users save them for reference.
  6. Any channel and purpose data entered into your Beam Draw objects will be transferred to your Lighting Devices.

 


 Move Beams to Layer

Overview

Once you have created a system of beams, you can easily move them to a new layer and begin a new system.

Instructions

  1. Select the beams you wish to file on another layer.  If no beams are selected, the command converts all beams on the current layer.
  2. Select the Move Beams to Layer menu.
  3. You will be prompted for a suffix name for the layer, usually the system name.  The layer name can be new or existing.
  4. The beams are moved.  New layers are hidden by default.

 


 Select Beams

Overview

Use thie command to select all Beam Draw objects.

 


 Select PAR Beams

Overview

Use thie command to select all Beam Draw PAR objects.

 


 Select Section Beams

Overview

Use thie command to select all Beam Draw Section objects.

 


 Select All Beams

Overview

Use thie command to select all Beam Draw object types, including PAR and Section.

 


 About Beam Draw…

Overview

Provides information about the current Beam Draw version and registration.  You can enter a purchased registration number or a requested demo code via this dialog.  There are also a number of support links in the dialog.

 


 Beam Draw FAQ

Overview

Go to the FAQ on the web.

 


 

 Beam Draw Help

Overview

Open this help doc.

 


 Submit a Beam Draw Bug

Overview

Submit a bug report on the web.

 


 

 Changing Default Parameters

To change the default parameters for all new documents, choose Tools>Scripts>VectorScript Plug-in Editor…, select Beam Draw, click the Parameters button, and edit the default values.  Please note, if you install an update the object, you will have to redo these custom settings.

SO_Change-Defaults

Last Updated on Tuesday, 18 April 2017 13:12
  Home > Vectorworks > Support > User Guides > Beam Draw 3 Users Guide